VMware View – Composer fails to join Windows XP VMs to the domain

This information is out there all over the place, but I still forget it even though I’ve bookmarked it, put it in OneNote, etc…so this post is another one of those that’s primarily serving as a reminder to myself.

When using VMware View and Composer to create VMs, the Customization process will result in an error stating that Composer could not join the VMs to the domain, even though it looks like everything is fine, computer objects are created, I can connect to the console of one of these VMs and login to the domain, etc. If you click the Error button in View Administrator, you’ll see the following

To correct the problem, install Microsoft update KB944043 onto the Windows XP parent VM.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7707

Now, maybe I’ll remember…hopefully before I deploy the first desktop pool. 🙂

1 Comment

Filed under VDI, VMware

One response to “VMware View – Composer fails to join Windows XP VMs to the domain

  1. Anonymous

    This solved my problem. Thank you so much for posting your very useful reminder 🙂

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s